
 

Introduction 
MediaReactor Proxy User Guide 
MediaReactor Proxy software was created in conjunction with Drastic Technologies' 
MediaReactor digital media file conversion software to allow the user to automatically 
convert incoming files into user-defined file types, using a "watch folder" to sense 
the arrival of incoming files, and scheduling conversion activity according to the 
user's preferences. 

Please review the following sections to learn how to use all the features of 
MediaReactor Proxy software. 

How to Use MediaReactor Proxy 

MediaReactor Proxy allows the user to set up a watched folder that senses incoming 
files and converts them to a file type of the user's choice. The user sets up what type 
of file will be created and how the file creation is handled. Multiple instances of 
MediaReactor Proxy may be run using different conversion and scheduling 
parameters to satisfy differing conversion and workflow requirements. 

Run MediaReactor Proxy 

Run MediaReactor Proxy via the start menu; Start Menu/ Programs/ MediaReactor/ 
MediaReactor_Proxy. The main interface will open. 

Set the Media File Type - Settings Dialog Box 

Open the Settings dialog box. The Settings dialog box can be accessed via the main 
menus, under Options/ Settings. Alternately the user may open this dialog box via 
the toolbar - press Config. Confirm that the settings are correct for the file type you 
need to create. Detailed descriptions of the settings are provided in the reference 
section of this document. 

Press the OK button  

Set the Media Creation Parameters - Folders Dialog Box 

Open the Folders dialog box. The Folders dialog box may be accessed via the main 
menus, under Options/Folders. Alternately the user may open this dialog box via the 
toolbar - press Folders. Confirm that the settings are correct for the way you want 
the conversions handled. Detailed descriptions of the settings are provided in the 
reference section of this document. 



Select the OK button once all of the choices have been addressed. 

If all the above parameters have been properly adjusted, MediaReactor Proxy (when 
running) will create the file types you have set up, in the folder of your choice, and 
with some flexibility as to when the files will be created. 

MediaReactor Proxy QuickStart 
Here is how to get started quickly using MediaReactor Proxy. Run MediaReactor 
Proxy: go to the Start Menu, under Programs/Drastic 
Technologies/MediaReactor/MediaReactor_Proxy. 

If this is the first time you have run MediaReactor Proxy, or if you have not saved a 
watch folder location, you will be prompted as to whether you want to create a watch 
folder.  

 

Select yes. The main MediaReactor Proxy interface will open. 

Open the Settings dialog box. This can be accessed through the Toolbar (select 
Config), or through the Main Menus (select Settings). For the purposes of this 
tutorial, set the following parameters: 

o Set the File Type to AVI.  
o Set the Codec ID to Cinepak.  
o Leave everything else in the default state. Close the Settings 

dialog box.  

Open the Folders dialog box via the main menus, under Options/ Folders, or through 
the Toolbar - press Folders. Set the following parameters: 

o Set the location of the Watch Folder.  
o Set the location of the Target folder.  
o Select the following media types: Video, Audio, Images.  
o Set the naming convention to: None.  
o Deselect any time settings.  
o Click OK. The Folders dialog box will close.  
o Add (copy or move) source media into the Watch Folder.  

For advanced users: create a shortcut to MediaReactor Proxy in your user's profile. 
Open your user's profile. Then find the MediaReactor program executable, right-click 
it and drag it onto your user's profile folder. Select the Create shortcut here option. 



 

Now browse to the location of a source media file. Right-click on the file.  

 

You will be able to select the option "Send to" the MediaReactor Proxy shortcut. Any 
suitable source media file may be converted using this method. 



Once MediaReactor Proxy has been set up, the user may copy or add files to the 
Watch Folder, and they will be converted. Essentially it is a "set it and forget it" 
application, which operates in the background according to the set parameters. 

MediaReactor Proxy Reference 
The Main Interface 

  

This reference work will look at each section in detail to provide information 
regarding the available controls and their functions. For the purposes of this 
reference work the interface has been divided into the following sections: 

1. Main Menus - access to all the controls of MediaReactor Proxy.  
2. Toolbar - quick push-button access to commonly used controls.  
3. Job List - displays the current conversion activity.  

The Main Menus 

The File Menu 

The File Menu allows the user to save and load configuration parameters, or to exit 
MediaReactor Proxy.  

 

1. Save Settings - opens a "Save As" dialog box, which allows the user to save the 



current conversion parameters. Multiple configuration files may be saved and run 
as separate instances of MediaReactor Proxy on the same system.  

2. 
Load Settings - opens a standard browser, which allows the user to search for a 
saved Settings file. Opening a saved settings file will load the parameters of this 
file into this instance of MediaReactor Proxy. 

3. Exit - stop any conversion activity in progress and close MediaReactor Proxy. 

Options Menu 

The Options Menu allows the user to view and adjust the parameters for conversion 
file types/ scheduling, and product licensing.  

 

1. Settings - opens the Settings dialog box, which allows the user to adjust the 
parameters for the type of file MediaReactor Proxy will create.  

2. Folders - opens the Folders dialog box, which allows the user to set up the 
manner in which the new files will be created. 

3. Authorization - opens the MediaReactor Proxy licensing dialog box, which allows 
the user to view and update the status of their license. 

4. License Information - displays the current license status 

Actions Menu 

The Actions Menu allows the user to affect the status of any conversions in progress. 

 

1. Pause - stop any conversions in progress, and prevent any new conversions 
from beginning. 

2. Resume - resume conversion activity - allow MediaReactor Proxy to check 
watched folders and create files according to the setup. 

3. Cancel - cancel the selected conversion. 
 



 

Help Menu 

The Help Menu offers any online Help Files including the About screen, which displays 
version information for MediaReactor Proxy. 

 

The Toolbar 

The Toolbar offers quick one-button access to some of the more commonly used 
commands within MediaReactor Proxy. 

 

1. Config - open the Setting dialog box, which allows the user to set up what type 
of files will be created. 

2. Folders - open the Folders dialog box, which allows the user to set up how the 
file conversions will be handled. 

3. Resume - resume conversion activity - allow MediaReactor Proxy to check 
watched folders and create files according to the setup. 

4. Pause - stop any conversions in progress, and prevent any new conversions 
from beginning. 

5. Cancel - cancel the selected conversion.  
6. Reset - reset the selected conversion. 

7. Help - the Help Menu offers any online help including the About screen, which 
displays version information for MediaReactor Proxy. 

 



 

The Settings Configuration Dialog Box 

Open the Settings Configuration dialog box via the main menus, under Options/ 
Settings, or via the toolbar - press Config. The following dialog box will open: 

 

1. (Video) File Type - select the Target video file type from the pulldown menu 

2. (Video) codec - select the codec for the Target video file type using the 
pulldown menu. 

3. Width/ Height Ratio - if supported, press the up or down buttons to 
increment the height and/or width of the Target video file. 

4. Key Frame - select between available Key Frame settings using the up or down 
arrows. 

5. 
(Video) Bit Depth, Quality, Data Rate - displays the settings for and offers 
controls to adjust the settings for these parameters, which affect image 
resolution and visual quality. 

6. Separate Audio - create an audio file separate from the video file - extract if 
necessary 

7. (Audio) File Type - select the Target audio file type from the pulldown menu. 
8. (Audio) Codec - select between available audio codecs for the Target file. 
9. (Audio) Sample Size, Sample Rate, Quality - displays the settings for and 



offers controls to adjust the settings for these parameters, which affect audio 
resolution, hence audio output quality. 

10. 
Dual Mono, Audio Only - select Dual Mono to create two matched mono audio 
files during the conversion. Select Audio Only to only create only audio files 
from the source file and not use the video portion of the file. 

11. Process - select the Process checkbox to enable processing to be applied 
during the conversion. 

12. 
Process Type, Edge, Thres - press the Process Type pulldown menu to select 
between available processes. The Type and Thres boxes allow the user to adjust 
the parameters of specific processes in legal increments. 

13. 2/3 Drop - select to apply 2/3 drop processing to incoming files. 

14. Add, Remove, A-Frame, Set - Add or remove Telecine-generated frames from 
an incoming file, or set the "A" Frame by time code. 

15. Pulldown Menu - adjust specific parameters of processing, if applicable. 

16. OK - accept current settings including any changes made, and close the 
Settings dialog box. 

 



 

The Folders Configuration Dialog Box 

Open the Folders Configuration dialog box via the main menus, under Options/ 
Folders, or through the Toolbar - press Folders. The following dialog box will open: 

 

1. Interval Search - search for files in the watched folder at the default interval 

2. Force Output - convert a file even though the new file has the same name as 
and overwrites an existing file in the target directory.  

3. Delete Source - delete the incoming (source) file upon completion of the 
Target file creation. 

4. 
(Source Media Filter) Video - select the Video checkbox to create a video file 
from an appropriate source (i.e. a video file) during the conversion. Must be 
selected in order for video files to be created. 

5. 
(Source Media Filter) Video - select the Audio checkbox to create an audio 
file from an appropriate source during the conversion. Must be selected in order 
for audio files to be created. 

6. 
(Source Media Filter) Images - select the Images checkbox to create Still 
Image file types from an appropriate source during the conversion. Must be 
selected in order for still image files to be created. 

7. Target Media Naming - Video - allows the user to attach a series of 
alphanumeric characters to the beginning (Prepend) or to the end (Append) of 



the video file name, or to leave the file name alone (select None). 

8. 
Timed Event checkbox - select the Timed Event checkbox to schedule 
conversion activity for specific time periods according to the constraints of your 
workflow requirements. 

9. 
Timer Interval - with the Timed Event checkbox selected, the user may then 
select either: 1). Set Timer Interval then enter an interval time in minutes, or 
2). Use Time Table, which uses the time periods set in the Conversion 
Scheduler to convert files. 

10. 
Source Folder - displays and allows the user to choose the "watched" directory 
in which the source files will arrive for conversion. Press the Source button to 
open a standard browser, which allows the user to search for an appropriate 
directory. 

11. 
Target Folder - displays and allows the user to choose the directory in which 
the completed files will be saved. Press the Target button to open a standard 
browser, which allows the user to search for an appropriate directory in which 
to store the target files. 

12. 
Completed Files Folder - displays and allows the user to choose the directory 
in which the source files will be saved upon completion of the conversion. Note 
that the Delete Source button must be unselected if you need to save the 
source files after the conversion has taken place. 

13. 
Target Naming - Audio - allows the user to attach a series of alphanumeric 
characters to the beginning (Prepend) or to the end (Append) of the audio file 
name(s), or to leave the file name alone (select None).  

14. Save Folder Settings - save the current settings of this folder as a file, which 
can be loaded as needed to perform similar conversions. 

15. Load Folder Settings - opens a standard browser, which allows the user to 
browse for and load a saved settings file for use. 

16. 
Conversion Scheduler - with the pulldown menu set to Use Time Table, the 
user may select and deselect time slots from the weekly schedule during which 
conversions will be processed. 

17. OK button - confirm the current settings or any changes made and close the 
Folder Settings dialog box. 

 


